Ospf Là Gì

     

OSPF – open Shortest Path First là 1 trong giao thức định tuyến link – state điển hình. Đây là 1 trong những giao thức được sử dụng rộng rãi trong những mạng công ty có kích cỡ lớn. Từng router lúc chạy giao thức vẫn gửi các trạng thái đường link của nó cho toàn bộ các router trong vùng (area). Sau một thời gian trao đổi, các router sẽ nhất quán được bảng cơ sở dữ liệu trạng thái đường link (Link State Database – LSDB) cùng với nhau, mỗi router đều có được phiên bản đồ mạng của cả vùng. Từ đó mỗi router sẽ chạy lời giải Dijkstra thống kê giám sát ra một cây lối đi ngắn duy nhất (Shortest Path Tree) và dựa vào cây này nhằm xây hình thành bảng định tuyến.

Bạn đang xem: Ospf là gì

1. Links State

Link State là giao thức kiến thiết đường đi tốt nhất có thể (Shortest path first) trải qua giải thuật Dijkstra. Những router chỉ việc trao đổi thông tin của nhau qua gói tin Hello mà không yêu cầu gửi cả bảng định tuyến. Sau khoản thời gian có thông tin nó sẽ xây dựng dựng ra một bảng định con đường và đường đi xuất sắc nhất.

Chỉ số AD: là chỉ số tin cẩn của các giao thức

Cost: là giá chỉ trị được xem theo cách làm 10^8/Bandwidth

OSPF chạy trên nền IP còn RIP chạy trên giao thức UDP

Các gói tin IP vận chuyện các gói tin OSPF thì ngôi trường Protocol- ID = 89

2. Cơ chế hoạt động của giao thức OSPF

Router đuổi theo OSPF thì nó buộc phải trải qua 4 bước:

Router ID

Thiết lập Neighbor

Trao thay đổi LSDB (Link State Database)

Xây dựng bảng định tuyến

a. Router ID là gì ?

Router IDđơn giản là 1 trong những giá trị dùng định danh cho Router khi sử dụng giao thức OSPF

Có định hình của một add IP A.B.C.D. Tất cả định dạng là địa chỉ cửa hàng IP chứ chưa phải là địa chỉ IP

Lấy IP cao nhấttrong cácInterface vẫn hoạt độngvàưu tiên cổng Loopback.

+ IP cao nhất: là địa chỉ IP cao nhất. IP gồm octet đầu cao hơn được xem như là lớn hơn

Vd: 1, 192.168.1.1,

2, 192.168.1.2, => là lớn số 1 (xét tự 192, tiếp đến sang 168 tiếp nối sang 1 và cuối cùng là 2)

3, 172.16.255.255,

4, 10.255.255.254.

Địa chỉ 2 > 1 > 3 > 4

Vậy ID của Router ở đây là 192.168.1.2

+ Interface active: là cổng đã (up/up) Status up cùng protocol up.

+ Cổng Loopback sẽ được ưu tiên hơn bởi vì nó không nhiều bị hỏng cùng ổn định.

b. Cấu hình thiết lập quan hệ nhẵn giềng

Các Router đang gửi gói tin Hello (10s/1 lần). Được dùng làm tìm ra router trơn giềng, chuyển một tình dục láng giềng lịch sự trạng thái 2 bước (2- Way), kế tiếp Hello giúp đo lường láng giếng khi nó bị lỗi.

Lần thứ nhất gói tin Hello gửi tới địa chỉ cửa hàng 224.0.0.6

2 Router phải thỏa mãn các điều kiện sau mới được điện thoại tư vấn là trơn giềng (phải bảo vệ 5 thông tin):

=> cùng Area-id: khi mạng lớn tín đồ ta chia làm nhiều vùng, vùng nào hỏng thì chỉ vùng đó chịu tác động. Từng một vùng đã đặt cho một Area-id. Vùng trung tâm gồm Area-id phải bởi 0. Phần đông vùng không giống phải tất cả đường truyền thẳng về vùng 0 nó bắt đầu truyền được dữ liệu.

=> cùng Subnet: 2 ip đề xuất cùng Subnet bắt đầu ping và điều đình được thông tin.

=> phải cùng thông số: Hello/Dead-time ở trên 2 cổng. Mặc định Hello là 10s, Dead là 40s sau 40s nó sẻ diệt kết nối.

=> đề xuất cùng bảo đảm trên 2 cổng. Giành cho mạng bự (metro). Khi để xác thực những router không giống không lấy được thông tin.

=> yêu cầu cùng cờ Stub Area Flag: giành cho OSPF đa vùng (học trong CCNP)

Để xem được sản phẩm xóm sử dụng lệnh: Show IP OSPF Neighbor

c. Trao đổi LSDB (Link State Database)

Mỗi Router mọi chưa một bảng LSDB

LSDP: links State Database. Bởi vì nó lớn vì thế nó chia bé dại ra thành các bạn dạng LSA nhằm gửi

LSA: link State Advertisement. Để gởi được LSA thì nó buộc phải đóng gói vào phiên bản tin LSU

LSU: là liên kết State Update. Để hội đàm và giữ hộ được LSU thì nó bao gồm 2 kiểu môi trường thiên nhiên gửi:

- Point - to lớn - Point: 2 router chạy với nhau theo giao thức HDLC hayPPP. Sau khoản thời gian nó kết nối được láng giềng thì chỉ có 2 Router trao đổi trực tiếp hotline là Full

- Broadcast Multiaccess: là nhiều Router liên kết với nhau thông qua một Swtich. R1, R2, R3, R4 cùng kết nối vào 1 Switch. Hôm nay nó hội đàm LSDB vẫn khác hoàng toàn.

Trong 4 Router sẽ bầu ra một Router làm DR-Desigted Router, 3 router còn lại sẽ bầu ra một BDR-Backup DR.

Các Router còn lại sẽ là DR Other. 2 Router là DR Other sẽ không còn gửi trực tiếp với nhau. Nó sẽ gửi tin tức về DR 1 bạn dạng và 1 bản cho BDR. Tiếp nối DR sẽ gửi phân phối xuống cho các Router còn lại.

DR Other vẫn gử tin tức về DR bằng địa chỉ 224.0.0.6. DR vẫn gửi LSDB đến DR Other là 224.0.0.5.

Xem thêm: Virus Idp.Generic Là Gì

Tiêu chí như thế nào được thai làm DR và BDR:

Trên mỗi cổng kết nối của các Router sẽ có một tham số: Priority(0-255) khoác định là 1. Nhỏ nào tối đa là DR và con nào thấp hơn là BDR.

Câu lệnh: R(config)# int F0/1 => R(config -if)# ip ospf priority (0-255)

Nếu không may có Priority là đều bằng nhau nó sẽ nhờ vào Router - ID. Router tất cả Router-id tối đa là DR

Nếu hệ thống đã gồm DR cùng BDR nếu cắm thêm một Router mới có DR cao hơn nó vẫn ưu tiên DR đang hoạt động.

Nếu để Priority là 0 nó sẽ không còn bầu DR tuyệt BDR

c. Kiến thiết bảng định đường nó dùng lời giải Dijkstra để mang ra con đường đi tốt nhất

3. Phương pháp tính Metric

Cost=10^8 /bandwidth

Băng thông cần đổi ra đơn vị: bps

Vd:

*

4. Cấu hình

a. Wildcard mask

Wildcard masklà một nguyên tắc lấy ra địa chỉ IP của một dải rất thiêng hoạt. Nó là 1 trong những dãy nhị phân 32 bit được dùng kèm cùng với một địa chỉ IP tham chiếu làm sao đó. Bit của showroom IP khớp ứng với Bit 0 là cố định, bit của IP tương ứng với bit 1 sẽ nạm định.

Vd: 192.168.1.0/24

Ta có: IP:192.168.1.0

WCM: 0 . 0 . 0.255

Vd: 192.168.1.32/27

Ta có: IP: 192.168.1.001xxxxx

WCM: 0 . 0 . 0 .00011111 => 0.0.0.31

b. Những lệnh cấu hình

Chạy OSPF

R(config)# Router OSPF Process-id (1-65535) chỉ có chân thành và ý nghĩa nội bộ.

R(config-Router)# network 192.168.1.0 0.0.0.31 area 0 (Areal là cùng mạng nhân tố này hết sức quan trọng)

R(config-Router)#default-information originate

Router(config-router)#redistribute connected subnet.

Hiệu chỉnh OSPF

Router - ID:

R(config)# Router OSPF 10

R(config-router)# router-id a.b.c.d (nhập ip vào, IP đó là ID)

Sau đó trở ra mode quản trị:

R(config)# Clear ip ospf process thì nó mới gồm hiệu lực

Priority:

R(config)# int f0/0

R(config-if)# ip ospf priority

Hello/Dead time:

R(config-if)# ip ospf hello-interval thời gian (là giây)

R(config-if)# ip ospf dead-interval thời hạn (là giây)

Xác thực trên 2 router

Vào vào cổng:

R(config-if)# ip ospf authentiacation

Nếu điền key:

R(config-if)# ip ospf authentiacation-key aptech

Các lệnh Show

Show ip router ospf

Show ip ospf neighbor

Show ip ospf database

Show ip ospf interface

Show ip protocol

5. Chú ý

Dùng lệnh Show ip router:

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.0.0.0 <110/20> via 192.168.1.20, 00:00:53, Serial0/1/0 => tương xứng #redistribute connected subnet.

C 192.168.1.0/24 is directly connected, Serial0/1/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 <110/65> via 192.168.1.20, 00:00:53, Serial0/1/0

O*E2 0.0.0.0/0 <110/1> via 192.168.1.20, 00:00:11, Serial0/1/0 => tương ứng: #default-information originate

II.Single-area và Multi-area OSPF

1. Thông số kỹ thuật Single-area OSPF

a. Chạy OSPF

R(config)# Router OSPF Process-id (1-65535) chỉ có ý nghĩa sâu sắc nội bộ.

R(config-Router)# network 192.168.1.0 0.0.0.31 area 0 (Areal là thuộc mạng nhân tố này hết sức quan trọng)

R(config-Router)#default-information originate

Router(config-router)#redistribute connected subnet.

b. Hiệu chỉnh OSPF

Router - ID

R(config)# Router OSPF 10

R(config-router)# router-id a.b.c.d (nhập ip vào, IP đó là ID)

Sau kia trở ra mode quản trị:

R(config)# Clear ip ospf process thì nó mới bao gồm hiệu lực

Priority

R(config)# int f0/0

R(config-if)# ip ospf priority

Hello/Dead time

R(config-if)# ip ospf hello-interval thời gian (là giây)

R(config-if)# ip ospf dead-interval thời gian (là giây)

c. Chuẩn xác trên 2 router

Vào trong cổng:

R(config-if)# ip ospf authentiacation

Nếu điền key:

R(config-if)# ip ospf authentiacation-key aptech

d. Các lệnh Show

Show ip router ospf

Show ip ospf neighbor

Show ip ospf database

Show ip ospf interface

Show ip protocol

2. Cấu hình Multi-area OSPF

a. Thông số kỹ thuật Multi-area

Router(config)#router ospf 5

Router(config-router)#redistribute ospf 10 subnet

b. Redistribute vào OSPF

RIP => OSPF

Router(config)#router ospf process-id

Router(config-router)#redistribute rip subnet.

EIGRP-OSPF

Router(config-router)#redistribute eigrp as-number subnet.

Static route và Default route => OSPF

Router(config-router)#redistribute static subnet.

Connected route => EIGRP

Router(config-router)#redistribute connected subnet.

Default route => OSPF

Router(config-router)#default-information originate.

Nếu bọn họ không đưa vào thông số metric thì mặc định metric sẽ tiến hành đặt cho tuyến được redistribute vào là 20.

Xem thêm: Cổng Line Out Là Gì ? Amply Không Có Cổng Line Line Out Là Gì

3. Chú ý

Dùng lệnh Show ip router:

10.0.0.0/24 is subnetted, 1 subnets

O E2 10.0.0.0 <110/20> via 192.168.1.20, 00:00:53, Serial0/1/0 => khớp ứng #redistribute connected subnet.

C 192.168.1.0/24 is directly connected, Serial0/1/0

C 192.168.2.0/24 is directly connected, FastEthernet0/0

O 192.168.3.0/24 <110/65> via 192.168.1.20, 00:00:53, Serial0/1/0

O*E2 0.0.0.0/0 <110/1> via 192.168.1.20, 00:00:11, Serial0/1/0 => tương ứng: #default-information originate