Native Vlan Là Gì

     

Có những các loại VLAN nào, nhắc tên các loại Vlan 

Một trong những khái niệm mà nhiều bạn nhầm lẫn khi học mạng, quản lí trị mạng hay gặp. Đó chính là Có những loại VLAN như thế nào ? Native vlan là gì ? bài viết này Kho ứng dụng Soft Folder đang giải đáp thắc mắc đó cho các bạn ! Hãy tìm hiểu trong nội dung bài viết sau !

Khái niệm Vlan là gì

Có 2 cách nhìn về VLAN

Nhìn trên một Switch

VLAN là một switch logical (ta có ổ cứng 80GB vật lý chia thành ổ C, D, E. Những ổ logical này là độc lập). Các VLAN chủ quyền sẽ không Forwarding sang trọng VLAN khác. VLAN sẽ không tồn tại bảng MAC của riêng nó cơ mà nó áp dụng chung bảng MAC của Switch đồ vật lý. Switch đồ lý sẽ xây dựng bảng MAC như sau:

VLANMACCổngVLANMACCổngVLANMACCổng
100.0c.0aF0/1200.0c.0nF0/11300.0c.n1F0/16
100.0c.05F0/2200.0b.0dF0/12300.0c.n2F0/17
100.0c.09F0/3200.0c.06F0/13300.0c.n3F0/18
100.0c.00F0/4200.0c.08F0/14300.0c.n4F0/19

Trên một Switch thứ lý chia thành 3 VLAN là VLAN 1, VLAN 2, VLAN 3. Sau thời điểm chia thì 3 VLAN sẽ tương xứng là 3 Switch độc lập. Trên một Switch 24 cổng ta bao gồm VLAN 1 bao gồm cổng từ 1-10, VLAN 2 bao gồm cổng tự 11-15, VLAN 3 gồm cổng từ 16-24. Những máy ngơi nghỉ VLAN 1 sẽ không còn trao thay đổi được với những máy ngơi nghỉ VLAN 3 vị 2 VLAN này khớp ứng 2 Switch độc lập.Bạn vẫn xem: Native vlan là gì


*

Vlan là gì – tư tưởng Vlan

+ nhìn trên cả một hệ thống: VLAN là một trong những Boroadcast domain.Bạn sẽ xem: Native vlan là gì

Xét bên trên 2 Switch trang bị lý:

+ mỗi Switch tạo thành 3 VLAN như là nhau. Hình thức là VLAN 1 của SW1 thông VLAN 1 của SW2, VLAN 2 của SW1 thông VLAN 2 của SW2, VLAN 3 thông VLAN 3.

Bạn đang xem: Native vlan là gì

SW1SW2
VLAN1VLAN1
VLAN2VLAN2
VLAN3VLAN3

+ Để VLAN 1 thông cùng nhau thì bên trên SW1 gặm dây vào một trong những cổng VLAN 1 kết nối sang cổng thuộc VLAN 1 của SW2, tựa như với VLAN2 và 3.

+ từng VLAN sẽ tương xứng một mạng hòa bình nên gọi là 1 trong những Broadcast domain.

Tại sao đề nghị chia VLAN (Virtual Local Area Network)

Xét hệ thống bình thường

Một doanh nghiệp giáo dục thuê một tòa nhà có tương đối nhiều tầng. Tầng 1 là khối văn phòng có một Switch (đây call là mạng LAN khối văn phòng bao hàm cả nhân viên cấp dưới tư vấn). Tầng 2 là phòng giám đốc đặt một Switch, Tầng 3 giảng viên đặt một Switch, tầng 4, 5 là của sinh viên. Toàn bộ các tầng những nối ra Router và ra internet. Tuy nhiên vào mùa tuyển chọn sinh thì số lớp sẽ ít nhưng hỗ trợ tư vấn viên phải nhiều (khối văn phòng gửi lên một ít ở tầng 4 với 5).

Phòng giám đốc nên thu thanh mảnh lại nhằm nhường phòng khác, nhưng phòng ban người có quyền lực cao lại chỉ bao gồm 3 hoặc 4 fan thì quá ra tương đối nhiều cổng. Khối hệ thống sẽ gồm sự tốn hèn khi có thiết bị cố kỉnh đổi.

Do cả tòa nhà cùng Router và đi ra internet đề xuất cùng dùng một dải mạng, cùng một Broadcast domain. Hệ thống sẽ không tồn tại độ bảo mật thông tin cao giữa những phòng ban. Lúc bị vi khuẩn thì cả hệ thống hoàn toàn có thể bị lây lan. Khi có một fan đứng trong mạng rất có thể bắt được hết tất cả gói tin toàn mạng trải qua Router.

Trong một công ty lớn có áp dụng nhiều yếu tố và áp dụng vào khối hệ thống mạng như: sử dụng Voice IP, truy vấn Web, Mail, truy vấn dữ liệu vào hệ thống. Nếu thông thường thì chẳng sao nhưng rủi ro bị ùn tắc thì đã lỗi cả hệ thống.


*

Vì sao cần được chia VlanXét hệ thống có thiết bị cung cấp VLAN

Vẫn những Switch vậy nên nhưng khi sử dụng VLAN nó chỉ việc kéo một dây trường đoản cú Router về một Switch như thế nào đó, tiếp nối sẽ phân tách VLAN

Trên một Switch 24 cổng nếu cung cấp VLAN thì nó đang chia nhỏ tuổi khu vực một phương pháp hợp lý: VLAN 1 tất cả cổng tự 1-10, VLAN 2 gồm cổng trường đoản cú 11-15, VLAN 3 bao gồm cổng từ 16-24.

Có các loại Vlan nào 

VLAN một là gì

Trong VLAN 1 có tương đối nhiều giao thức ở Lớp 2 chuyển động giao tiếp với nhau như: CDP, PagP, VTP; nên đây đó là lý do vì sao VLAN 1 được chọn làm dạng hình mạng mang định và rất dễ thấy trên các thiết bị mạng có cung cấp tính năng phân chia mạng ảo của Cisco System.

Xem thêm: Định Nghĩa Payload Là Gì - Cách Phòng Chống Payload

Default VLAN là gì

Là đẳng cấp VLAN khoác định thuở đầu với toàn bộ các cổng giao tiếp trên thiết bị gửi mạch. Do vậy mặc định VLAN cũng rất có thể hiểu là VLAN 1, và các VLAN khác như User VLAN, Native VLAN, Management VLAN hầu như là những thành phần bé của default VLAN.

User VLAN (hay Data VLAN) 

Là VLAN trong những số đó chứa những tài khoản người dùng thành từng đội dựa theo các thuộc tính về đặc thù các bước của từng nhóm làm việc hay theo ở trong tính về địa điểm vật lý của những nhóm thao tác làm việc này.

Native VLAN là gì 

Native VLAN là một trong những VLAN được thực hiện để cấu hình Trunking do một số trong những thiết bị không cân xứng với nhau. Lúc một cổng của switch được thông số kỹ thuật trunk, vào phần tag của frame đi qua cổng đó sẽ tiến hành thêm một số hiệu VLAN ưa thích hợp.

Tất cả các frames thuộc những VLAN khi đi qua đường trunk sẽ tiến hành gắn thêm các tag của giao thức 802.1q với ISL, ngoại trừ những frame của VLAN 1. Như vậy, theo khoác định những frames của VLAN 1 khi đi qua đường trunk sẽ không còn được lắp tag.

Native VLAN hoàn toàn có thể được gửi thành VLAN khác bằng câu lệnh như sau :

Switch(config-if)#switchport trunk native vlan vlan-id

Lưu ý : so với Native VLAN bọn họ không yêu cầu sử dụng như là user VLAN xuất xắc management VLAN.

Management VLAN là gì

Để hoàn toàn có thể giám gần cạnh từ xa các thiết bị gửi mạch trong hệ thống mạng của mình, bạn cần phải có một VLAN đặc trưng dùng để tiến hành việc này, đó đó là Management VLAN. Bằng phương pháp gán một showroom IP dùng để telnet từ xa vào hệ thống mạng thông qua địa chỉ IP này, và rất có thể cấm các người tiêu dùng khác truy vấn vào thiết bị.

Vì đấy là một VLAN hơi nhạy cảm được cấp một trong những quyền cai quản trị đề nghị nó rất cần được được bóc riêng ra khỏi những VLAN khác để bảo vệ yếu tố an toàn bảo mật. Lúc mạng có vấn đề như: quy tụ với STP, broadcast storms thì một Management VLAN được cho phép nhà quản trị vẫn hoàn toàn có thể truy cập được vào trang bị và xử lý vấn đề đó.

Xem thêm: Phép Nối Là Gì - Các Dạng Phép Nối

Cấu hình địa chỉ IP cho Switch

Switch#config terminal

Switch(config)#interface vlan vlan-id

Switch(config-if)#ip address xxx.xxx.xxx.xxx subnet mask

Switch(config-if)#end

Địa chỉ này sẽ được sử dụng để quản trị Switch trường đoản cú xa (qua telnet). Xxx.xxx.xxx.xxx là địa chỉ cửa hàng IP của VLAN. Ví dụ: 192.168.10.2 lấy một ví dụ subnet mask là 255.255.255.0

Voice VLAN là gì

Một số câu lệnh cấu hình VLAN hay gặp

Câu lệnh để tên mang đến VLAN

SW(config)# Vlan 2

SW(config-vlan)# name IT

SW(config-vlan)# exit

Câu lệnh gán cổng mang lại VLAN

SW(config)# interface range f0/1-5

SW(config-if-range)#switchport access vlan 2

Cậu lệnh Gán Trunking mang lại cổng

+ Đối với dòng 2900 nó cung cấp sẵn dot1Q buộc phải không yêu cầu bật. Chỉ việc vào cổng bật Trunk lên là xong

SW(config)# interface f0/24

SW(config-if)#switchport mode trunk

+ Đối với loại 3500 trở lên đề nghị vào bật dot1Q xuất xắc ISL nó mới chạy. Còn nếu như không bật đang báo lỗi:

SW(config)# interface f0/24

SW(config-if)#switchport trunk encapsulation SW(config-if)#switchport mode trunk

Chú ý: hay gán cổng trunk chạy quý phái Switch không giống hoặc về Router.

Câu lệnh Gán Native VLAN vào VLAN quản lí lý

SW(config)# Vlan 100

SW(config-vlan)# name Managerment

SW(config-vlan)# exit

SW(config)# interface f0/24 (phải bao gồm 2 lệnh)

SW(config-if)#switchport access vlan 100

SW(config-if)#switchport native vlan 100

SW(config-if)#exit

SW(config)#interface vlan 100

SW(config-if)#ip địa chỉ 192.168.1.1 255.255.255.0

Cấu hình trên thực tế về VLAN1, VLAN NATIVE, VLAN mặc định trên thuộc VLAN1

SW0(config)#interface vlan 1

SW0(config-if)#ip địa chỉ cửa hàng 11.0.0.254 255.255.255.0

SW0(config-if)#no shut

SW0(config-if)#exit

SW1(config)#interface vlan 1

SW0(config-if)#ip địa chỉ 11.0.0.253 255.255.255.0

SW0(config-if)#no shut

SW0(config-if)#exit

CORE(config)#interface f0/0.1

CORE(config-subif)#encapsulation dot1Q 1

CORE(config-subif)#ip địa chỉ cửa hàng 11.0.0.1 255.255.255.0

CORE(config-subif)#exit

Trên toàn bộ các máy đều phải kê mật khẩu

SW(config)#line console 0

SW(config-line)#password abc

SW(config-line)#login

SW(config-line)#exit

SW(config)#line vty 0 4

SW(config-line)#password abc

SW(config-line)#login

SW(config-line)#exit

SW(config)#enable secret cisco

Trên PC cần sử dụng lệnh: telnet 11.0.0.x để truy cập từ xa

Các lệnh bình chọn vlan hay gặp

SW(config)# Show vlan

SW(config)# Show vlan brief

SW(config)# Show interfaces trunk

SW(config)# Show mac-address-table

chú ý: file cấu hình VLAN đặt trong bộ lưu trữ flash là: vlan.dad. Không lưu giữ trong tệp tin Running config