Dhcp snooping là gì

     
Cách thực hiện cấu hình DHCP Snooping bên trên switch CiscoCách thực hiện thông số kỹ thuật DHCP bên trên router CiscoCấu hình router cấp IP độngCấu hình router cung cấp IP cố định và thắt chặt cho client

Trong sản phẩm công nghệ tính, DHCP Snooping là 1 loạt phần nhiều kỹ thuật được áp dụng để nâng cấp tính bảo mật thông tin của DHCP. Chỉ các DHCP hệ thống được admin cho phép mới có quyền cung cấp DHCP cho máy tính trong mạng. Đọc bài viết dưới đây để biết phương pháp thực hiện cấu hình DHCP bên trên switch cùng router của Cisco.

Bạn đang xem: Dhcp snooping là gì

DHCP Snooping là gì?

DHCP Snooping hoàn toàn có thể xem như một nhân tài của tường lửa. Tuấn kiệt này giúp ngăn chặn những cuộc tiến công của tin tặc vào hệ thống mạng cùng đánh cắp những thông tin đặc trưng của doanh nghiệp. Hầu như tin tặc vẫn gửi thông tin hàng fake để gạt gẫm phần mềm của sản phẩm tính. Tự đó, chuyển tài liệu của người tiêu dùng đến gateway đưa mạo.

Mục đích của các hacker là biến chuyển “man in the middle”. Khi đã làm cho được điều này, máy tính sẽ gửi biểu hiện đến gateway để tin báo ra mạng mặt ngoài. Từ bỏ đó, tin tặc sẽ phân tích mọi dữ liệu của người tiêu dùng rồi chuyển mang đến gateway giả - đó là máy tính của họ.

Nhờ bản lĩnh của DHCP Snooping, IP Source, Dynamic tích thích hợp trên switch Cisco, máy vi tính của các bạn sẽ được bảo đảm và ngăn chặn khỏi những cuộc tấn công này.

Ví dụ: laptop mà các bạn sử dụng rất có thể nhận add IP, DNS, gateway,... Ví như hacker tấn công thì sẽ xây dựng dựng một khối hệ thống DHCP hàng nhái cùng mạng mạng internet với máy tính mà ai đang sử dụng. Khi máy tính gửi Broadcast DHCP Request, server DHCP đưa mạo rất có thể gửi thông tin vấn đáp làm đồ vật tính của bạn nhận nhầm server giả là gateway. Lúc này, những dữ liệu sẽ tiến hành gửi ra mạng phía bên ngoài thông qua gateway giả. Hacker sẽ phân tích cùng lấy các dữ liệu quan trọng đặc biệt mà không tồn tại một cảnh báo. Đây là 1 trong dạng tiến công được call là “man in the middle”, nghĩa là tin tặc sẽ chuyển đổi đường truyền của dữ liệu mà người tiêu dùng không thể phát hiện nay được.

*

DHCP Snooping là gì?

Nguyên lý buổi giao lưu của chế độ DHCP

Để ngăn chặn cuộc tiến công này, các bạn nên thực hiện DHCP Snooping. Khi chính sách này được kích hoạt, những cổng trên switch đã phân nhiều loại thành gần như cổng tin cậy (trusted) và không tin cậy (untrusted). đầy đủ cổng tin yêu sẽ thừa nhận DHCP Reply gắn với server DHCP. Trong lúc đó, các cổng không tin tưởng cậy đang nhận DHCP Request thêm với máy vi tính của fan dùng. Ngoài ra, DHCP Snooping còn thực hiện phân tích phần nhiều gói DHCP Request, Reply, tạo bảng cửa hàng dữ liệu địa chỉ cửa hàng IP được cấp, MAC cùng cổng thông tin mà máy tính xách tay đó trực thuộc.

Cách thực hiện cấu hình DHCP Snooping trên switch Cisco

Bước 1: Bật anh tài DHCP Snooping toàn bộ trên switch Cisco

“SW1(config)#ip dhcp snooping.

SW2(config)#ip dhcp snooping.

SW3(config)#ip dhcp snooping.”

Bước 2: nhảy DHCP Snooping bên trên VLAN 10

“SW1(config)#ip dhcp snooping vlan 10.

SW2(config)#ip dhcp snooping vlan 10.

SW3(config)#ip dhcp snooping vlan 10.”

Bước 3: vô hiệu hóa tùy lựa chọn 82 được chèn trong gói DHCP

“SW1(config)#no ip dhcp snooping information option.

SW2(config)#no ip dhcp snooping information option.

SW3(config)#no ip dhcp snooping information option.”

Bước 4: Xác định thông số kỹ thuật những giao diện an toàn trên các mạch gửi (Những giao diện kết nối với DHCP máy chủ hợp pháp)

“SW1(config)# interface GigabitEthernet0/1

SW1(config-if)# ip dhcp snooping trust”.

 

“SW2(config)# interface GigabitEthernet0/1

SW2(config-if)# ip dhcp snooping trust”.

 

“SW3(config)# interface FastEthernet0/1

SW3(config-if)# ip dhcp snooping trust”.

Bước 5: Xác định cấu hình giới hạn tốc độ với số đông yêu ước DHCP từ lắp thêm khách (tùy chọn)

“SW1(config)# interface FastEthernet0/1

SW1(config-if)# ip dhcp snooping limit rate 20”.

 

“SW2(config)# interface FastEthernet0/1

SW2(config-if)# ip dhcp snooping limit rate 20”.

Xem thêm: " Bridge The Gap Là Gì ? Câu Trả Lời Đúng Nhất! Bridge The Gap Nghĩa Là Gì

 

“SW3(config)# interface FastEthernet0/1

SW3(config-if)# ip dhcp snooping limit rate 20”.

Bước 6: Xác minh DHCP trên switch Cisco

SW1#show ip dhcp snooping

“Switch DHCP snooping is enabled

DHCP snooping is configured on following VLANs:

10

Insertion of option 82 is disabled

Option 82 on untrusted port is not allowed

Verification of hwaddr field is enabled

Interface Trusted Rate limit (pps)

 

———————– ——- —————-

GigabitEthernet0/1 yes unlimited

FastEthernet0/1 no 20”.

SW2#show ip dhcp snooping

“Switch DHCP snooping is enabled

DHCP snooping is configured on following VLANs:

10

Insertion of option 82 is disabled

Option 82 on untrusted port is not allowed

Verification of hwaddr field is enabled

Interface Trusted Rate limit (pps)

 

———————– ——- —————-

 

GigabitEthernet0/1 yes unlimited

FastEthernet0/1 no 20”.

SW3#show ip dhcp snooping

“Switch DHCP snooping is enabled

DHCP snooping is configured on following VLANs:

10

Insertion of option 82 is disabled

circuit-id mặc định format: vlan-mod-port

remote-id: 0001.9641.6CBE (MAC)

Option 82 on untrusted port is not allowed

Verification of hwaddr field is enabled

Verification of giaddr field is enabled

DHCP snooping trust/rate is configured on the following Interfaces:

Interface Trusted Allow option Rate limit (pps)

———————– ——- ———— —————-

FastEthernet0/1 yes yes unlimited”.

*

Cách thực hiện cấu hình DHCP bên trên Switch Cisco

Cuối cùng, bạn đã sở hữu cấu hình DHCP Cisco trên những switch như sau:

Switch 1

“SW1#show run

hostname SW1

!

ip dhcp snooping vlan 10

no ip dhcp snooping information option

ip dhcp snooping

!

interface FastEthernet0/1

switchport access vlan 10

ip dhcp snooping limit rate 20

switchport mode access

!

!

interface GigabitEthernet0/1

ip dhcp snooping trust

switchport mode trunk

!”

Switch 2

“SW2#show run

hostname SW2

!

ip dhcp snooping vlan 10

no ip dhcp snooping information option

ip dhcp snooping

!

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport access vlan 10

ip dhcp snooping limit rate 20

switchport mode access

!

!

interface GigabitEthernet0/1

ip dhcp snooping trust

switchport mode trunk

!”

Switch 3

“SW3# show run

!

ip dhcp snooping vlan 10

no ip dhcp snooping information option

ip dhcp snooping

!

interface FastEthernet0/1

ip dhcp snooping trust

switchport access vlan 10

switchport mode access

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk”.

Cách thực hiện thông số kỹ thuật DHCP trên router Cisco

Cấu hình router cấp IP động

Trên router Cisco

Bước 1: Thực hiện thông số kỹ thuật cơ bạn dạng cho router đặt IP.

“Router(config)#interface f0/0

Router(config-if)#ip address 10.0.0.1 255.255.255.0

Router(config-if)#no shutdown”.

Tiếp đến, bật dịch vụ DHCP: “Router(config)#service dhcp”.

Bước 2: sinh sản 1 pool để cấp cho IP đến client.

“Router(config)#ip dhcp pool Network_10 (Bạn hoàn toàn có thể đặt tên khác cho pool cấp cho IP)

Router(dhcp-config)#network 10.0.0.0 255.255.255.0

Router(dhcp-config)#default-router 10.0.0.1

Router(dhcp-config)#dns-server 8.8.8.8 8.8.4.4”.

Bước 3: tạo thành 1 dãy IP để loại trừ. IP này không được cấp cho client mà thực hiện cho các server.

“Router(config)#ip dhcp excluded-address 10.0.0.1 10.0.0.10”.

Bước 4: Để xem lại cấu hình DHCP router Cisco, các bạn nhập câu lệnh sau: “Router(config)#show ip dhcp binding”.

Trên PC 1

Bạn áp dụng lệnh nhằm xóa IP và xin cung cấp DHCP Snooping.

“C:Documents & Settingspc1> ipconfig /release

C:Documents & Settingspc1> ipconfig /renew”.

*

Cách thực hiện cấu hình DHCP trên router Cisco cung cấp IP động

Cấu hình router cấp cho IP cố định và thắt chặt cho client

Trên clientTrên router

“Router(config)#ip dhcp pool PC2

Router(dhcp-config)#host 10.0.0.100 255.255.255.0

Router(dhcp-config)#client-identifier 0100.5056.3D7A.3C

Router(dhcp-config)#default-router 10.0.0.1

Router(dhcp-config)#dns-server 10.0.0.1”.

Xem thêm: Nhận Định Doraemon Có Nghĩa Là Gì, Doraemon Là Gì

Bước 2: các bạn xem lại cấu hình DHCP Snooping bên trên router.

Lời kết

Trên đây là những thông tin cơ bản về DHCP Snooping và bí quyết thực hiện. Nếu bạn muốn lắp đặt mạng của các hãng công nghệ thông tin trên thay giới, vincitysdaimo.com sẽ là việc lựa chọn hoàn hảo. Contact ngay hỗ trợ tư vấn để được hỗ trợ tư vấn và cung ứng nhanh giường nhé!